RufzXP

Marco Tullio Cicerone

RufzXP "Tancredi"

(Per aspera ad astra)

Marco Tullio Cicerone

Cos'è RufzXP ?

"Rufz" è l'abbreviazione della parola tedesca "Rufzeichen-Hören" il cui significato è "ascolto di nominativi". RufzXP è un eccellente programma d'allenamento per aumentare la velocità e la pratica del CW, in modo particolare la ricezione "a memoria" di nominativi radioamatoriali ad (ultra) alta velocità. Focalizzato sul miglioramento dell'efficienza del CW, non è un simulatore di contest e non utilizza QRM durante le trasmissioni. E' provvisto di strumenti addizionali per memorizzare i progressi compiuti e compararli con quelli di altri utenti, tramite la pubblicazione dei record nella TopList Internazionale del RufzXP.

RufzXP è un "must" per ogni radiotelegrafista seriamente interessato all'alta velocità ed è una prova ufficiale dei Compionati IARU di Telegrafia.

Il suffisso "XP" indica che questa versione, completamente nuova, sfrutta tutte le caratteristiche della più recente tecnologia informatica ed è progettata specificatamente per MS Windows XP (funziona perfettamente anche con le versioni 2000, NT, ME e 98).

Per chi ha già avuto qualche esperienza con le versioni precedenti del Rufz (Rufz32, ad esempio), c'è veramente poco da dire: le regole sono le stesse, il modo di calcolare il punteggio è all'incirca il medesimo e gli errori portano alle ben conosciute conseguenze; chi conosce bene le parti menzionate può saltare direttamente alla sezione RufzXP - Caratteristiche tecniche ma, in ogni caso, è consigliata a tutti la lettura completa della documentazione.

Attenzione: è possibile richiamare la documentazione relativa a qualsiasi finestra tramite la pressione del tasto F1!

RufzXP - Qualche considerazione...

Tutti i software della serie Rufz sono stati creati per un unico scopo: il miglioramento, spinto ai limiti estremi (o, comunque, a quelli prefissati), della ricezione del codice Morse. La filosofia che sta alla base del programma è semplice quanto antica: "Per aspera ad astra" (ovvero: "attraverso le difficoltà si giunge alle stelle" - Cicerone) che, a ben vedere, è un po' il motto di ogni radioamatore che si rispetti. Come ottenere, infatti, dei risultati ragguardevoli senza la tenacia, la grinta e lo studio metodico giornaliero?

RufzXP è lo strumento ideale per questo scopo ed è in grado di migliorare in modo straordinario le capacità di ricezione del codice Morse. Attenzione: un uso prolungato provoca assuefazione! :-)

Il tentativo

Il funzionamento è presto spiegato: avviando il tentativo viene prima richiesto il nominativo personale (massima lunghezza consentita: 8 caratteri), la velocità con cui si desidera iniziare e, dopo qualche istante, ha inizio il tentativo stesso (durante la modalità HST e solamente per motivi di classificazione, verranno richiesti anche il titolo e la data di nascita dell'utente). Una volta iniziato, vengono trasmessi i nominativi e, fra una trasmissione e l'altra, il RufzXP si pone in attesa di una risposta da parte dell'utente: una volta ricevuta, basandosi sulla velocità di trasmissione, sulla lunghezza del nominativo, sul numero degli eventuali errori e sul tempo impiegato per rispondere, calcola il punteggio ottenuto e varia la velocità di trasmissione del nominativo successivo: in caso di ricezione corretta la velocità verrà aumentata, altrimenti diminuita.

Durante il tentativo, sono disponibili alcune features, come il controllo del volume e la possibilità di nascondere o spegnere velocemente il programma (rispettivamente, Shift+F4 e Shift+F10). Per maggiori dettagli, si rimanda alla documentazione relativa alla Finestra principale.

Il funzionamento del RufzXP, come si può dedurre, è quanto di più semplice si possa immaginare: in ogni caso, si consiglia una lettura delle sezioni specifiche per un approfondimento sul suo utilizzo.

RufzXP - caratteristiche tecniche

RufzXP, come il suo predecessore, si basa su di una serie di semplici quanto efficaci algoritmi; senza addentrarsi troppo nei dettagli, sono stati individuati due punti fissi su cui basare il motore della serie Rufz:

  1. se il nominativo è stato ricevuto correttamente, la velocità di trasmissione verrà aumentata: in caso contrario, diminuita

  2. il punteggio viene calcolato tenendo conto della velocità di trasmissione (influenza quadratica), della lunghezza del nominativo (influenza lineare), del numero degli errori (influenza quadratica) a del tempo impiegato a rispondere (influenza logaritmica)

Le velocità, salvo che nella modalità Trainer, sono prefissate e selezionabili da una lista: durante una sessione d'allenamento, invece, è possibile definirne la modalità d'incremento (lineare o percentuale dall'1% al 5%).

Nel tempo, sono state perfezionate una serie di formule che, tenendo conto dei fattori summenzionati, forniscono un reale riscontro delle capacità di ricezione del codice Morse: nello stesso tempo, dato che si tratta di un software ludico, assegna una serie di punteggi che permettono di valutare in modo realistico l'effettivo aumento delle proprie prestazioni (ogni tanto, qualche gratificazione ci vuole! :-D).

Riguardo al file system, RufzXP sfrutta ampiamente le possibilità offerte dal Framework: tutto il software, compresi i file di configurazione, si trova in un'unica cartella (nessun valore viene memorizzato nel registro di sistema!) e, volendo, può essere spostato senza alcun tipo di limitazione (anche se si consiglia l'utilizzo dell'apposito software per l'installazione e la rimozione del programma).

  1. Cartella Attempts: contiene tutti i dati relativi ai singoli tentativi (uno per file);

  2. Cartella Attempts: contiene tutti i dati relativi ai singoli tentativi (uno per file);

  3. Cartella Backgrounds: contiene gli sfondi utilizzabili da RufzXP. Quello selezionato viene visualizzato a finestra principale ingrandita

  4. Cartella Help: contiene la documentazione d'aiuto (fra cui, questo file che state leggendo)

  5. Cartella Languages: contiene i file di traduzione (uno per lingua)

  6. Cartella PrsData: contiene, uno per file, i dati personali degli utenti. Vengono utilizzati per la registrazione e la pubblicazione, sul sito ufficiale, dei record ottenuti

  7. Personal callbase.txt: un archivio nominativi personalizzato (a scopo dimostrativo: non sono presenti nella distribuzione ufficiale)

  8. File Config.rfz: file di configurazione principale

  9. File ScoreBoard (Rufz32).scb e ScoreBoard.scb: due archivi record (a scopo dimostrativo: non sono presenti nella distribuzione ufficiale). E' possibile utilizzarne solamente uno alla volta ma nulla vieta di ripartire i dati dei tentativi, a seconda delle occasioni, su più archivi

  10. File RufzXP.exe: programma principale

  11. File Microsoft.DirectX.dll e Microsoft.DirectX.DirectSound.dll: librerie utilizzate per l'implementazione della tecnologia DirectX.

Novità di RufzXP

Le novità sono molteplici e si potranno scoprire utilizzando il programma. Alcune, fra le principali, sono le seguenti:

  • Presenza della modalità trainer

  • Possibilità di creare ed utilizzare degli archivi nominativi personalizzati (callbase), da utilizzarsi solamente durante le modalità Contest e Trainer

  • Possibilità di utilizzare diversi archivi record (scoreboard: uno alla volta)

  • Possibilità di inviare i record personali, direttamente via internet o utilizzando il proprio client per la posta elettronica, per la pubblicazione nella TopList mondiale

  • Possibilità di creare dei contest "ad hoc" e di salvarne le impostazioni (per un utilizzo successivo o per condividerle con altri utenti)

  • Ampia configurabilità delle modalità disponibili: è possibile infatti modificare i parametri principali d'ognuna, dove non ci siano delle limitazioni predefinite

  • Ampia configurabilità delle opzioni principali del software (tentativo nascosto, attivazione o disattivazione degli effetti sonori, ecc., ecc.)

Ognuna di queste opzioni è ampiamente spiegata nella relativa sezione.

Requisiti

  • MS Windows 98, ME, 2000, XP

  • MS -NET Framework 1.1, o superiore, versione redistributable

  • MS DirectX 9, o superiore, versione runtime


AttemtpForm - Finestra principale

Finestra principale

(Attempt Form - Finestra principale)

Questa è la finestra principale: da qui, infatti, è possibile iniziare un tentativo, una sessione d'allenamento o una gara (Contest o HST). E' inoltre possibile, tramite i vari menù, accedere agli Strumenti del programma, cambiare la modalità o leggere le pagine dell'Help .

La finestra è suddivisa in 5 parti principali.

La prima, dal titolo Tentativo in corso, espone i dati relativi all'intero tentativo; più precisamente:

  • Punteggio attuale: punteggio massimo istantaneo acquisito

  • Nominativi (o Gruppi) errati: numero di nominativi, o gruppi, ricevuti erroneamente

  • Velocità iniziale principale o trainer: velocità (espressa in cpm o wpm) con la quale si è deciso di iniziare il tentativo

  • Velocità massima: velocità massima raggiunta durante tutto il tentativo (espressa in cpm o wpm)

  • Velocità minima: velocità minima raggiunta durante tutto il tentativo

La seconda, visibile solamente durante il tentativo stesso, è suddivisa in due sottofinestre (una a destra e l'altra a sinistra): nella prima viene mostrato il nominativo trasmesso mentre, nella seconda, quello ricevuto.

In quest'ultima, com'è naturale, vengono evidenziati gli errori (a meno che non si sia deciso di nascondere le risposte selezionando la voce Nascondi tentativo nella finestra Opzioni: in questo caso, durante i modi HST e Contest, verranno mostrati solamente i dati relativi al punteggio totale ed alla velocità impiegata per rispondere; durante le modalità TopList e Trainer, invece, queste sottofinestre saranno completamente nascoste). Per permettere un riconoscimento immediato della correttezza o inesattezza della risposta, viene utilizzato un codice colore.

La terza, dal titolo Ultimo nominativo, espone i dati istantanei relativi all'ultimo indicativo (o gruppo) trasmesso; più precisamente:

  • Velocità attuale: velocità a cui è stato trasmesso l'ultimo nominativo

  • Punteggio massimo: punteggio massimo disponibile in caso di ricezione perfetta dell'ultimo nominativo trasmesso (per perfetta si intende una ricezione esente da errori ed effettuata nel minimo tempo impiegabile). E' calcolato principalmente in base alla velocità di trasmissione (influenza quadratica) e, secondariamente, in base alla lunghezza del nominativo o del gruppo (influenza lineare)

  • Punteggio effettivo: punteggio effettivamente conseguito nella ricezione dell'ultimo nominativo trasmesso. E' calcolato in base al numero di errori effettuati ed al tempo impiegato per la risposta (NB: come nelle versioni precedenti del Rufz, 1 errore riduce il punteggio ad 1/4, 2 errori ad 1/9 e 3 errori ad 1/16. Novità; per acquisire un punteggio, è necessario ricevere correttamente almeno la metà dei caratteri trasmessi: in caso contrario, vengono assegnati zero punti. E' presente, inoltre, una riduzione logaritmica del punteggio, correlata al tempo di risposta. L'utilizzo del tasto F6 (singola ritrasmissione del nominativo) dimezza il punteggio)

  • Errori: numero di errori effettuati durante la ricezione dell'ultimo nominativo (o gruppo)

  • Tempo necessario: tempo impiegato per ricevere e rispondere, calcolato dalla fine della trasmissione fino alla pressione del tasto INVIO (espresso in millisecondi)

La quarta parte è utilizzata come finestra di dialogo per l'immissione dei dati richiesti, come il nominativo, la velocità iniziale ed i caratteri ricevuti oppure per attivare o disattivare la modalità VIGM: nella prima metà, durante il tentativo e secondo la modalità VIGM, viene evidenziato o solamente il numero progressivo del gruppo trasmesso (gruppo trasmesso:totale gruppi) oppure i dati sensibili del tentativo mentre la seconda viene utilizzata per l'input da parte dell'utente.

La quinta e ultima parte contiene i pulsanti che consentono di iniziare, interrompere (o sospendere momentaneamente) il tentativo, uscire dal programma e modificare il volume di trasmissione.

Sono inoltre disponibili le seguenti scorciatoie da tastiera:

  • ESC: interruzione (o sospensione temporanea) del tentativo

  • PageUP: il volume aumenta di 5 unità

  • PageDOWN: il volume diminuisce di 5 unità

  • Shift + PageUP: volume al 50%

  • Shift + PageDOWN: volume al 50%

  • Shift + F4: il programma viene ridotto ad icona e posto nella "task bar"

  • Shift + F10: chiusura immediata del programma


AttemtpForm - Settings

Finestra principale

Impostazioni delle modalità

(AttemptForm - Mode settings)

Il RufzXP offre la possibilità di utilizzare 4 modalità principali:

  • TopList

  • Trainer

  • Contest

  • HST

Grazie al menù Settaggi, è possibile modificare i parametri delle modalità Contest e Trainer.


AttemptForm Menus

Menù della finestra principale

(AttemptForm - Form del tentativo)

Tramite i menù è possibile accedere a tutte le funzioni del RufzXP, come indicato nelle seguenti tabelle:

Menù Strumenti:

Inizio (F5)

Avvia il tentativo.

Dati ultimo tentativo (F3)

Se attivo, mostra tutti i dati relativi all'ultimo tentativo sostenuto (classifica, operatore, punteggio, errori e velocità più la lista dettagliata di tutti i gruppi trasmessi)

Archivio record (F4)

Mostra il contenuto dell'archivio record (Scoreboard) attivo. Al suo interno sono presenti, uno ogni singola riga, i dati relativi ai tentativi effettuati ordinati per punteggio.

International TopList (CTRL+F12)

Confronta il tentativo dal punteggio più elevato con i risultati contenuti nella TopList internazionale (scaricata automaticamente dal sito web del RufzXP e salvata localmente). Viene visualizzata immediatamente una classifica provvisoria. Questa voce di menù è visibile solamente se la relativa opzione è selezionata (finestra delle opzioni).

Invia record (F6)

Da questa finestra è possibile inviare, via internet, il proprio record personale (punteggio più alto) per la pubblicazione nella Toplist internazionale di RufzXP.

Password (F7)

Permette l'attivazione o la cancellazione di una password per la protezione dell'accesso ai settaggi del programma. Questa voce non è attiva durante le modalità Contest e HST.

Opzioni (F2)

Apre la finestra Opzioni: da qui, è possibile modificare tutti le principali opzioni del RufzXP (vedi finestra Opzioni).

Lingua (F9)

Apre la finestra Lingua: da questa, è possibile selezionare il linguaggio preferito. Durante la prima installazione, viene mostrata automaticamente.

Esci (10)

Determina l'uscita dal RufzXP.

Menù Modalità:

TopList

Modalità di default. Durante il tentativo, vengono inviati 50 nominativi, prelevati casualmente dall'archivio principale: una percentuale, variabile dal 4% al 20%, è riservata agli indicativi complessi (quelli contenenti il simbolo "/").

Trainer

Modalità consigliata per perfezionare gradualmente la ricezione del codice Morse. Tramite il menù Settaggi è possibile selezionare i caratteri con cui effettuare l'esercitazione, la lunghezza e la composizione del gruppo trasmesso, la lunghezza della sessione e la percentuale di nominativi complessi, la velocità di trasmissione, gli archivi da utilizzare e la pesatura del codice Morse.

Contest

Modalità Contest libero. E' possibile selezionare, tramite il menù Settaggi, la lunghezza del tentativo, la percentuale dei nominativi complessi, il numero massimo di tentativi consentiti ad un singolo utente e gli archivi utilizzati (sia per la trasmissione dei nominativi che per la memorizzazione dei record). In questa modalità è consentito l'utilizzo di archivi nominativi personalizzati.

Prima dell'attivazione della modalità è richiesta l'attivazione di una password: quest'ultima verrà utilizzata per la modifica delle opzioni, dei settaggi e per la disattivazione della modalità stessa.

HST

Modalità HST (High Speed Telegraphy - Telegrafia ad alta velocità). Questa modalità è utilizzata durante i campionati mondiali IARU HST. La lunghezza del tentativo è fissa (50 nominativi) così come la percentuale di indicativi complessi (10% = 5 indicativi).

Prima dell'attivazione della modalità è richiesta l'attivazione di una password: quest'ultima verrà utilizzata per la modifica delle opzioni e per la disattivazione della modalità stessa.

Settaggi (F11)

Menù attivo solamente durante le modalità Trainer e Contest. Permetta la modifica delle opzioni specifiche relative alla modalità selezionata.

Menù Suono (F12):

Questo menù diventa disponibile solamente durante le modalità Contest ed HST.

Permette, durante una gara, la modifica di tutti i parametri del suono (frequenza, fade in e fade out e forma d'onda)

Menù Lingua:

English

Questa opzione, assieme al menù Lingua, diventa disponibile solamente durante le modalità Contest ed HST (in caso contrario, è comunque accessibile dalla finestra Opzioni).

Permette di selezionare la lingua Inglese.

Altre lingue

Questa opzione, assieme al menù Lingua, diventa disponibile solamente durante le modalità Contest ed HST (in caso contrario, è comunque accessibile dalla finestra Opzioni).

Permette la selezione, se disponibile, della lingua specificata (nell'immagine a lato, quella italiana).

Menù Aiuto:

Istruzioni (F1)

Mostra la documentazione in linea (questo Help file).

Istruzioni rapide (F8)

RufzXP in breve.

TopList

Collegamento alla TopList on-line.

Sito Web

Sito ufficiale del RufzXP. E' possibile trovare tutte le informazioni inerenti il programma, compresa l'ultima versione disponibile.

Mailing list

Mailing list ufficiale del programma RufzXP.

Contatta gli autori (Email)

Questo menù è visibile solamente se un client di posta elettronica di default è installato e definito (ad esempio: Outlook, Outlook Express, Netscape, Eudora, Pegasus, Elm, Pine, etc.): in questo caso, permette di scrivere direttamente agli autori (per segnalare degli errori, effettuare delle richieste o per proporre delle nuove idee) aprendo un messaggio pre-indirizzato.

Contatta gli autori (WebForm)

Nel caso sia disponibile una connessione ad Internet, permette di contattare direttamente gli autori (per segnalare degli errori, effettuare delle richieste o per proporre delle nuove idee) aprendo un web form predefinito: in caso contrario, un breve messaggio di aiuto indicherà l'indirizzo a cui rivolgersi.

Ricerca aggiornamenti

Apre il planner degli aggiornamenti. Da questa finestra è possibile selezionare l'intervallo di controllo (giornaliero, settimanale, mensile), il modo (manuale, automatico, mai) ed effettuare un controllo immediato (se è disponibile una connessione ad Internet).

Autori e ringraziamenti

Curriculum vitae, fotografie ed informazioni varie sui programmatori del RufzXP e ringraziamenti ai sostenitori.

Copyright

Mostra le informazioni riguardanti il copyright.

Informazioni su RufzXP

Mostra la versione del programma.

Mailing list:

Informazioni

Informazioni riguardanti la mailing list di RufzXP (argomento, come iscriversi, come gestire il proprio account, ecc., ecc.).

Archivio

Collegamento all'archivio della mailing list del RufzXP. Tutti gli articoli pubblicati sono consultabili in questa pagina.

Scrivi un articolo

Questo menù è visibile solamente se un client di posta elettronica di default è installato e definito (ad esempio: Outlook, Outlook Express, Netscape, Eudora, Pegasus, Elm, Pine, etc.): in questo caso, permette di scrivere un articolo alla mailing list di RufzXP aprendo un messaggio pre-indirizzato.


AttemptForm - Status bar

Barra di stato della finestra principale

(AttemptForm - Status bar)

A seconda della modalità selezionata, la barra di stato della finestra principale (la parte più bassa della finestra stessa), riporta le seguenti informazioni:

Modalità TopList
  • Dati relativi all'archivio nominativi (totale nominativi [indicativi semplici - indicativi complessi])
  • Punteggio: il punteggio più elevato presente nell'archivio record attivo
  • Velocità: velocità massima presente nell'archivio record attivo
  • Tentativi: numero di tentativi effettuati registrati nell'archivio record attivo

Modalità Trainer
  • Gruppi utilizzati: i gruppi di caratteri da utilizzare durante la sessione
  • Punteggio: il punteggio più elevato presente nell'archivio record attivo
  • Velocità: velocità massima presente nell'archivio record attivo
  • Tentativo: numero di tentativi effettuati registrati nell'archivio record attivo

Modalità Contest

La barra di stato, per motivi di riservatezza riguardo ai record effettuati durante la modalità Contest, non viene visualizzata!

Modalità HST

 La barra di stato, per motivi di riservatezza riguardo ai record effettuati durante la modalità HST, non viene visualizzata!


Modalità

RufzXP - Modalità


Free contest mode

Modalità contest libero

(Free contest mode)

La modalità contest libero è stata implementata per permettere, a chiunque lo desideri, la creazione di un proprio modello di gara. L'ampia configurabilità di questa modalità permette infatti di intervenire su ogni aspetto di un contest: numero di nominativi trasmesso durante il tentativo, percentuale dei nominativi complessi da trasmettere, numero di tentativi permessi ad un singolo partecipante, archivi record separati e, soprattutto, selezione di un archivio nominativi personalizzato.

I punti cardine per il contest, come per tutte le altre modalità del RufzXP (trainer a parte), restano invariati:

  • Velocità variabile secondo le consuete regole del Rufz;

  • Calcolo del punteggio, sempre secondo le consuete regole del Rufz;

Questa versione, in particolare, introduce alcuni miglioramenti a livello di gestione del contest: ad esempio, prima dell'inizio del tentativo vero e proprio, esiste la possibilità di effettuare una prova di ricezione selezionando il pulsante Test (posto fra il tasto Esci ed il controllo del volume). Così facendo, una volta inserita la velocità (che rimarrà fissa sino alla fine del TEST), inizia la trasmissione di 5 nominativi: si consiglia di approfittare di questo momento per prendere confidenza con la tastiera e regolare il volume di trasmissione.

Attivazione della modalità Contest

Come per l'attivazione della modalità HST, prima di tutto viene richiesta la creazione ed attivazione di una password: questa servirà a consentire l'accesso alle parti sensibili del programma solamente alle persone autorizzate; viene richiesta nei seguenti casi:

  • Accesso alla finestra delle Opzioni (una versione ridotta, limitata alla definizione del suono, è comunque disponibile premendo il tasto F12)

  • Accesso alla finestra dei Settaggi

  • Cambio di modalità: in questo caso, l'inserimento della password corretta ha come conseguenza la sua cancellazione (a tutti gli effetti, non ce n'è più bisogno)

  • Uscita dal programma principale

  • Attivazione del programma principale

Ultimata con successo questa procedura, segnalata dalla presenza di una chiave in alto a sinistra della finestra ( [image]), la modalità viene attivata.

Caratteristiche specifiche

Durante la modalità Contest libero non viene bloccata di default la visualizzazione dei dati durante il tentativo: è possibile però nasconderla, qualora lo si desideri, o tramite la pressione dell'apposito pulsante oppure selezionando il controllo appropriato nella finestra delle Opzioni.. La barra di stato, quando visualizzata, non riporta comunque i dati relativi ai record effettuati precedentemente. E' inoltre impossibile interrompere il tentativo tramite la pressione del tasto ESC (potrebbe essere premuto accidentalmente): è permesso, invece, fermare il tentativo cliccando sul tasto Interrompi..

Una volta ultimato, vengono evidenziati solamente i risultati relativi al tentativo appena terminato (che, come sempre, si svolge secondo le regole generali): la classifica, per motivi di riservatezza, durante la gara non viene invece mai mostrata.

Il punteggio ottenuto durante questa modalità non è considerato valido per la pubblicazione nella TopList Internazionale.

Settaggi

Una volta selezionata la modalità Contest, è possibile modificarne le opzioni attraverso la finestra Settaggi, richiamabile dal menù Modalità della finestra principale (F11).

  • Archivio nominativi; è possibile utilizzarne solamente una versione personalizzata

  • Archivio record; è possibile utilizzare un archivio record qualsiasi

  • Tx per tentativo: da un minimo di 10 ad un massimo di 999 (default: 50)

  • Tentativi per utente: da un minimo di 1 ad un massimo di 999 (default: 10)

  • Nominativi barrati: da un minimo di 0 (nessun nominativo complesso) ad un massimo del 100% (solamente nominativi complessi)

  • Ripristino archivio nominativi ufficiale: nel caso sia stata selezionata precedentemente una versione personalizzata, ripristina l'archivio nominativi Ufficiale.

  • Crea nuovo archivio record: permette la creazione di un archivio record vuoto

Menù File

Tramite questo menù è possibile aprire o salvare le impostazione del contest libero (per condividerle o, semplicemente, per poterle richiamare in un secondo momento).

  • Apri: permette il recupero e l'attivazione delle impostazioni salvate precedentemente in un file

  • Salva: permette il salvataggio, in un file, delle impostazioni attive del contest libero


HST mode

Modalità contest HST

(HST contest mode)

L'HST (acronimo di High Speed Telegraphy - Telegrafia ad alta velocità) altro non è che una delle prove ufficiali sostenute durante i campionati IARU HST. Le sue regole, come tutte le altre, sono semplici:

  • 2 tentativi per utente, 50 nominativi trasmessi (5 complessi e 45 semplici) secondo le regole dei campionati IARU HST.

  • Velocità variabile secondo le consuete regole del Rufz;

  • Calcolo del punteggio, sempre secondo le consuete regole del Rufz;

Questa versione, in particolare, introduce alcune migliorie a livello di gestione del contest: ad esempio, prima dell'inizio del tentativo vero e proprio, esiste la possibilità di effettuare una prova di ricezione selezionando il pulsante Test. Così facendo, una volta inserita la velocità (che rimarrà fissa sino alla fine del TEST), inizia la trasmissione di 5 nominativi: si consiglia di approfittare di questo momento per prendere confidenza con la tastiera e regolare il volume di trasmissione. E' inoltre possibile nascondere i dati relativi al tentativo in corso tramite la pressione dell'apposito pulsante.

Attivazione della modalità HST

Come per l'attivazione della modalità contest libero, prima di tutto viene richiesta la creazione ed attivazione di una password: questa servirà a consentire l'accesso alle parti sensibili del programma solamente alle persone autorizzate; viene richiesta nei seguenti casi:

  • Accesso alla finestra delle Opzioni (una versione ridotta, limitata alla definizione del suono, è comunque disponibile premendo il tasto F12)

  • Cambio di modalità: in questo caso, l'inserimento della password corretta ha come conseguenza la sua cancellazione (a tutti gli effetti, non ce n'è più bisogno)

  • Uscita dal programma principale

  • Attivazione del programma principale

Ultimata con successo questa procedura, segnalata dalla presenza di una chiave in alto a sinistra della finestra ( [image]), la modalità viene attivata.

Caratteristiche specifiche

Durante la modalità HST è inoltre impossibile interrompere il tentativo tramite la pressione del tasto ESC (potrebbe essere premuto accidentalmente): è permesso, invece, fermare il tentativo cliccando sul tasto Interrompi. Una volta ultimato, vengono evidenziati solamente i risultati relativi al tentativo appena terminato (che, come sempre, si svolge secondo le regole generali): la classifica invece, per motivi di riservatezza, non viene mai mostrata durante la gara.

Settaggi

Date le regole prefissate del modo HST, il menù settaggi non è disponibile per questa modalità.


Trainer Mode

Modalità trainer

(Trainer mode)

Questa è una delle nuove modalità messe a disposizione dal RufzXP: grazie a questa, è possibile esercitarsi creando degli esercizi ad hoc o selezionando i caratteri di cui si desidera migliorare la ricezione. La modalità viene selezionata scegliendo la voce apposita dal menù Modalità, presente nella finestra principale, e si svolge esattamente come un normale tentativo (come per quest'ultimo, è possibile impostare un nominativo principale e la velocità iniziale dalla finestra Opzioni).

Settaggi

L'utilizzo di questa finestra di dialogo, richiamabile tramite la pressione del tasto F11, è molto intuitivo ma, in ogni caso, verrà fornita una breve descrizione delle parti principali che la compongono.

Selezione caratteri:

Alla sinistra della finestra sono presenti 3 gruppi di caratteri: lettere, numeri e simboli. La loro attivazione è determinata dal controllo Modalità Trainer: tramite questo, infatti, è possibile selezionare, come mostrato dalla tabella seguente, la categoria di caratteri (o la modalità) sui quali allenarsi:

  1. Modalità RufzXP: tutte e 3 le liste di selezione dei caratteri sono disabilitate.

  2. Archivio nominativi personale: tutte e 3 le liste di selezione dei caratteri sono disabilitate.

  3. Ham code: tutte e 3 le liste di selezione dei caratteri sono disabilitate.

  4. Modalità mista HST: tutte e 3 le liste di selezione dei caratteri sono disabilitate.

  5. Lettere: è attiva solamente la prima lista.

  6. Numeri: è attiva solamente la seconda lista.

  7. Simboli: è attiva solamente la terza lista.

  8. Lettere e numeri: sono attive la prima e la seconda lista.

  9. Lettere e simboli: sono attive la prima e la terza lista.

  10. Numeri e simboli: sono attive la seconda e la terza lista.

  11. Tutti: tutte e 3 le liste sono attive.

Per le selezioni dai punti 3 al 9 (quelle che implicano la scelta dei caratteri), sono resi disponibili, per ognuna delle liste attive, 3 pulsanti:

  • Tutti: seleziona tutti i caratteri presenti nella lista

  • Nessuno: deseleziona tutti i caratteri presenti nella lista

  • Inverti: inverte la selezione

Attenzione: perché la selezione venga ritenuta valida, devono esser scelti almeno 2 caratteri (è infatti impossibile, quanto inutile, esercitarsi nella ricezione di uno solo).

Modalità Trainer:

E' possibile selezionare, per la sessione d'allenamento, una delle seguenti 11 modalità:

  1. Modalità RufzXP: esattamente come avviene nella modalità TopList, vengono selezionati casualmente e trasmessi dei nominativi dall'archivio principale. Vengono disabilitate, di conseguenza, la maggior parte delle opzioni: resta comunque possibile selezionare la Lunghezza del tentativo, un Archivio record, la Pesatura morse e la Velocità .

  2. Archivio nominativi personale; simile al precedente ma con una differenza sostanziale: è possibile creare un file di testo contenente una lista personalizzata di nominativi (o gruppi) da trasmettere. Le opzioni disponibili sono: Archivio nominativi, Archivio record, Velocità, Lunghezza tentativo, Nominativi barrati e Pesatura morse.

  3. Ham code: per migliorare la ricezione del CW di uso comune, vengono trasmesse, durante la sessione d'allenamento, le abbreviazioni utilizzate più di frequente dalla comunità radioamatoriale (inclusi alcuni estratti del codice Q e del codice 92).

  4. Modalità mista HST: vengono preselezionati automaticamente i caratteri richiesti durante le competizioni HST: 26 lettere (tutte), 10 numeri (tutti) e 5 simboli (/.=,?).

  5. Lettere: è possibile selezionare, dalla prima lista, le lettere da utilizzare nella sessione d'allenamento.

  6. Numeri:è possibile selezionare, dalla seconda lista, i numeri da utilizzare nalla sessione d'allenamento

  7. Simboli: è possibile selezionare, dalla terza lista, i simboli da utilizzare nella sessione d'allenamento

  8. Lettere e numeri: è possibile selezionare, dalle prime due liste, le lettere ed i numeri da utilizzare nella sessione d'allenamento

  9. Lettere e simboli: è possibile selezionare, dalla prima e dalla terza lista, le lettere ed i simboli da utilizzare nella sessione d'allenamento

  10. Numeri e simboli: è possibile selezionare, dalla seconda e dalla terza lista, i numeri ed i simboli da utilizzare nella sessione d'allenamento

  11. Tutti: è possibile selezionare, da tutte e 3 le liste, le lettere, i numeri ed i simboli da utilizzare nella sessione d'allenamento.

Lunghezza gruppi:

Determina la lunghezza dei gruppi che verranno trasmessi durante la sessione d'allenamento; le possibilità offerte sono 2:

  • Fissa: ogni gruppo verrà generato esattamente della lunghezza richiesta (più facile)

  • Variabile: ogni gruppo potrà avere una lunghezza variabile (è possibile definirne il limite superiore ed inferiore) (più difficile)

Composizione gruppi:

Quest'opzione è attiva solamente se vengono selezionate almeno 2 liste di caratteri. Determina la composizione dei singoli gruppi trasmessi:

  • Misti: i gruppi di caratteri selezionati vengono mischiati all'interno delle stesso gruppo (ad esempio, lettere con numeri, simboli con numeri, ecc., ecc.)

  • Separati: all'interno di un gruppo verranno inseriti solamente caratteri appartenenti alla stessa lista di selezione (solo lettere, solo numeri o solo simboli)

Esempio di selezione mista di gruppi di 5 caratteri (lettere e numeri):

AE4F7 3HJU0 TG2DB 897D5

Esempio di selezione separata di gruppi di 5 caratteri (lettere e numeri):

AEFHT 89765 FFJEP DJJNM 77463

Velocità:

Determina il calcolo della tabella delle velocità durante la sessione d'allenamento ed il tipo di incremento.

  • Fissa: la velocità non viene ricalcolata. Ogni singolo gruppo verrà trasmesso alla velocità specificata nella finestra Opzioni.

  • Variabile: la velocità viene incrementata o decrementata secondo le regole generali del Rufz (in base agli errori commessi)

  • Incrementale: la velocità, in caso di ricezione corretta, viene incrementata secondo le regole generali del RufzXP ma, in caso di errore, rimane fissa (non viene decrementata)

  • Incremento velocità: lineare o percentuale (dall'1% al 5%). Determina l'intervallo fra i valori della tabella delle velocità utilizzata durante la modalità Trainer.

Selezione database:

Tramite questi pulsanti, è possibile selezionare sia un archivio nominativi che uno record. Le singole opzioni sono disponibili, o meno, a seconda della Modalità trainer selezionata (ad esempio, il pulsante Archivio nominativi è disponibile solamente quando è selezionata la modalità Archivio nominativi personale).

Lunghezza tentativo:

Tramite questo controllo è possibile selezionare il numero di gruppi che verranno trasmessi durante la sessione, da un minimo di 10 ad un massimo di 9999 (default: 20).

Cronometro:

Se selezionato, la sessione d'allenamento sarà a tempo. Durante il tentativo verrà mostrato un cronometro e, allo scadere del tempo preselezionato, la sessione verrà interrotta.

Minuti:

Limite di tempo per ultimare una sessione d'allenamento (1-59 minuti).

Nominativi barrati:

Tramite questo controllo è possibile selezionare, solamente se la modalità attiva è Archivio nominativi personale, la percentuale di nominativi complessi (contenenti la barra) che verranno inseriti nella sessione. La percentuale selezionabile deve poter corrispondere all'effettivo contenuto dell'archivio nominativi proposto (se la percentuale di nominativi complessi presente è, ad esempio, del 10% è impossibile selezionarne una più elevata): in ogni caso, il programma impedisce il verificarsi di quest'eccezione impostando automaticamente il limite selezionabile in base all'archivio caricato.

Pesatura morse:

Per pesatura del codice Morse si intende la proporzione esistente fra il punto, la linea e lo spazio utilizzato per separare due parole. L'unità di misura è sempre il punto e RufzXP offre le seguenti pesature:

  • 1:2:5 (Difficile)

  • 1:2:7

  • 1:3:5

  • 1:3:7 (Predefinito: questa è la pesatura utilizzata normalmente nelle modalità TopList ed HST)

  • 1:4:5

  • 1:4:7 (Facile)

Ad esempio, per 1:3:5 si intende quanto segue:

  • Punto: 1 unità (1 punto :-) )

  • Linea: 3 unità (3 punti)

  • Spazio fra parole: 5 unità (5 punti)

Pulsanti di selezione:

Sono 4 ed il loro utilizzo è intuitivo:

  • Nuovo archivio record: crea un archivio record completamente vuoto

  • Ripristino archivio nominativi ufficiale: nel caso sia stata selezionata precedentemente una versione personalizzata, ripristina l'archivio nominativi Ufficiale.

  • OK: conferma le selezioni effettuate, chiude la finestra dei settaggi e ritorno a quella principale

  • Cancella: chiude la finestra dei settaggi e ritorna a quella principale senza salvare le eventuali selezioni (ogni modifica andrà quindi persa)


Finestre accessorie

RufzXP - Finestre accessorie


Results form

Finestra dei risultati

(Results form)

Questa finestra espone i dati dettagliati relativi ad un tentativo sostenuto e viene mostrata automaticamente al termine dello stesso; è inoltre possibile richiamarla direttamente dalla classifica generale (doppio click sulla riga relativa al tentativo di cui si desiderano i dettagli).

La finestra è divisa in due settori distinti; nel primo (a sinistra), vengono mostrati i dati globali: nel secondo, quelli relativi ad ogni singolo nominativo, o gruppo, trasmesso.

Posizione in classifica (solamente nella modalità TopList)

Errori commessi nella ricezione di un singolo nominativo (o gruppo)

Nominativo trasmesso (l'eventuale ritrasmissione, tramite pressione del tasto F6, è evidenziata da un puntino rosso)

Nominativo ricevuto (gli errori vengono evidenziati utilizzando un codice colore)

Velocità con la quale è stato trasmesso il singolo nominativo

Punteggio massimo disponibile per il singolo nominativo

Punteggio effettivamente acquisito

Tempo impiegato per rispondere (in millisecondi)

Frequenza utilizzata durante la trasmissione (in Herz)

Operatore

Punteggio acquisito

Nominativi (o Gruppi) errati

Velocità massima raggiunta durante il tentativo

Velocità minima raggiunta durante il tentativo

Durante i contest, invece, i dati relativi alla classifica non vengono evidenziati.

Il doppio click su una riga (o la pressione del tasto Invio mentre una riga è selezionata) ritrasmette il nominativo evidenziato (o gruppo).

Menù File

Tramite il menù file è possibile accedere alla stampa ed all'esportazione dei dati relativi al tentativo selezionato.

Le opzioni di stampa sono quelle standard: è possibile, infatti, selezionare la stampante, impostare il tipo di carta ed i margini del foglio e, per finire, visualizzare il preview di stampa.

E' possibile esportare i dati in 3 formati diversi:

· RTF (Rich Text Format): i dati vengono esportati mantenendo sia la formattazione (si consiglia l'orientamento orizzontale della pagina) che il codice colore per l'evidenziazione degli errori

· TXT (Testo): i dati vengono esportati in un file di testo, utilizzando la barra verticale "|" come separatore di campo

· CSV (Comma Separated Values): i dati vengono esportati utilizzando il formato CSV (richiamabile, ad esempio, da Excel o dalla maggior parte dei fogli di calcolo)

Modalità di visualizzazione

Tramite questa voce di menù, è possibile visualizzare il tentativo completo o limitarlo agli errori di ricezione. Quest'opzione è disponibile solamente se il tentativo contiene almeno un nominativo ricevuto erroneamente.


Scoreboard

Finestra dell'archivio record

(Scoreboard form)

Questa finestra, come si può facilmente intuire, espone la classifica generale contenuta nell'archivio record attivo. A seconda di quanto specificato nella finestra delle Opzioni, viene mostrata automaticamente, o meno, alla fine di ogni tentativo.

Nella parte superiore, vengono evidenziati i seguenti dati:

  • Record punteggio: il punteggio più altro presente nell'archivio record attivo

  • Record velocità: velocità massima presente nell'archivio record attivo

  • Totale tentativi: numero totale di tentativi presenti nell'archivio record attivo

Nella parte centrale, invece, vengono esposti i dati veri e propri; ogni riga corrisponde ad un tentativo, di cui vengono forniti i seguenti valori:

Classifica: posizione nella classifica generale

Nominativo: identificativo personale dell'utente che ha sostenuto il tentativo

Punteggio: punti conseguiti durante il tentativo

Velocità massima: velocità massima di ricezione raggiunta durante il tentativo

Tentativo: numero progressivo del tentativo sostenuto

Data: data in cui è stato sostenuto il tentativo (l'ora, pur essendo registrata, non viene mostrata)

Nella parte inferiore della finestra sono presenti alcuni controlli che permettono il filtraggio dei dati (visualizzazione selettiva), l'invio e la cancellazione dei record selezionati.

Selezione dei record

E' possibile selezionare uno o più record utilizzando il metodo standard implementato dai sistemi windows:

  • Selezione singola: evidenziare il record, tramite la barra colorata, utilizzando o la tastiera (cursori) o il mouse

  • Selezione multipla sequenziale: evidenziare il primo record che si desidera selezionare, premere il tasto SHIFT e, mantenendolo premuto, cliccare con il mouse sull'ultimo record necessario

  • Selezione multipla selettiva: mantenendo premuto il tasto CTRL, cliccare sui record che si desiderano includere della selezione

Se lo si desidera, è possibile combinare le selezioni multiple.

Nota bene: cliccando sul record selezionato, o premendo il tasto invio, verranno richiamati i dati specifici (se disponibili: vedi opzioni) del tentativo evidenziato per mezzo della finestra dei risultati.

Cancellazione dei record

Cliccando sul tasto Cancella record, posto in basso a destra, è possibile cancellare i record selezionati. Una volta confermata l'operazione, il tentativo viene rimosso dall'archivio record attivo e non è più recuperabile.

Invio record

Questa è una delle novità presenti nel RufzXP; il tasto Invia record richiama una finestra di dialogo, dalla quale è possibile procedere all'invio del singolo record selezionato (non è permessa la selezione multipla: in ogni caso, verrebbe inviato il primo record evidenziato). Per tutte le specifiche, si raccomanda la lettura della sezione dedicata all'invio dei record.

Filtro nominativi

Anche questa è una funzione dall'utilizzo semplice ed intuitivo; aprendo l'elenco a scorrimento, è possibile selezionare l'identificativo dell'utente di cui si desidera visualizzare i tentativi: selezionando la voce ---Lista completa---, invece, verrà mostrato l'intero contenuto dell'archivio record. Naturalmente, il controllo è attivo e disponibile solamente nel caso in cui ci siano più utenti all'interno dell'archivio record attivo.

Menù File

Tramite questo menù è possibile importare un archivio record, esportare i dati relativi al tentativo selezionato (o, tramite una selezione multipla, a più tentativi), operare una selezione totale sull'archivio presente ed effettuare le normali operazioni di stampa.

Importazione archivi record (F2)

E' possibile importare qualsiasi archivio record esistente, sia generato da RufzXP che dalle versioni precedenti (per mezzo del file RUFZTOPL.TXT). La differenza sostanziale consiste nel fatto che tutti i record generati da quest'ultime (ad esempio, da Rufz32) non vengono considerati validi ai fini della classifica generale pubblicata su internet: per evidenziare questa limitazione, i dati relativi al tentativi vengono mostrati in colore grigio (non attivi).

Esportazione dati tentativo (F3)

E' possibile esportare, in un archivio dei record (file *.scb, *.csv o *.txt), i dati relativi al tentativo selezionato (o, tramite una selezione multipla, a più tentativi). L'archivio record di destinazione, se esiste, verrà sovrascritto.

Esportazione lista completa (F11)

E' possibile esportare, in un archivio dei record (file *.scb, *.csv o *.txt), i dati relativi a tutti i tentativi (lista completa). L'archivio record di destinazione, se esiste, verrà sovrascritto.

Filtro nominativi (F4)

Scorciatoia per il filtro dei nominativi.

Inverti selezione (CTRL + F5)

Grazie a questo menù, è possibile invertire la selezione dei record (selezionato <> non selezionato).

Seleziona tutto - Deseleziona tutto (F5)

Tramite questa funzione è possibile selezionare, con una sola operazione, tutto il contenuto dell'archivio record; è disponibile anche la funzione opposta: una volta che tutto l'archivio è stato selezionato, è possibile deselezionarlo completamente sempre con la stessa funzione (in questo caso, la voce del menù viene modificata in Deseleziona tutto.

International TopList (CTRL+F12)

Grazie a questo menù, è possibile comparare il tentativo selezionato con i risultati presenti nella TopList internazionale: la graduatoria provvisoria viene visualizzata immediatamente. La lista è prelevata dal sito web del RufzXP e salvata sul PC per un utilizzo locale: alla scadenza, viene aggiornata automaticamente. Questa voce di menù è visibile solamente se la relativa opzione è selezionata (finestra delle opzioni).

Invia record (F6)

Da questa finestra è possibile inviare, via internet, il record selezionato per la pubblicazione nella Toplist internazionale di RufzXP.

Stampa - Impostazioni pagina - Preview di stampa (F7 - F8 - F9)

Queste 3 voci corrispondono alle operazioni standard di stampa, presenti in quasi tutti i programmi esistenti; è possibile, infatti, selezionare la stampante, impostarne i margini, l'orientamento ed il tipo della carta. E' inoltre disponibile la possibilità di visualizzare un'anteprima di stampa.

Esci (F10)

Chiude la finestra dell'archivio risultati.

Menù "Modalità archivio record"

Tramite questo menù è possibile impostare la modalità di visualizzazione dei record presenti nell'archivio attivo.

Le opzioni disponibili sono 2, di facile comprensione ed utilizzo:

  • Tutti i record: visualizza tutti i record

  • Migliori punteggi per nominativo: visualizza il numero richiesto di record per nominativo, selezionandoli fra i migliori disponibili

  • Seleziona punteggi per nominativo: permette di selezionare il numero di record da visualizzare: questo menù è utilizzabile (e visibile) solamente se l'opzione precedente è attiva.


Send record

Finestra per l'invio dei record

(Send record form)

Questa è una delle novità presenti nel RufzXP. Per mezzo di questa finestra di dialogo, infatti, è possibile inviare il tentativo selezionato dalla finestra archivio record per la pubblicazione nella Toplist Internazionale del RufzXP (direttamente via internet o utilizzando il proprio client per la posta elettronica, come Outlook Express, Eudora, Pegasus, Pine, ecc., ecc.).

I dati principali del tentativo che verrà inviato (nominativo dell'utente, punteggio massimo e velocità massima ottenuta) sono visibili nelle due etichette in alto a sinistra.

La finestra di dialogo è divisa in due parti:

  1. La parte superiore contiene dei campi la cui compilazione è richiesta per l'aggiornamento del database della TopList di RufzXP

  2. La parte inferiore, contrassegnata dall'etichetta Dati email utente, contiene dei campi la cui compilazione è richiesta per l'invio diretto del record tramite un server SMTP

Nominativo TopList

Spesso, il nominativo/nome utente registrato presso la TopList Internazionale del RufzXP è differente da quello utilizzato per conseguire un nuovo record: in questo caso, la specifica di un nominativo/nome utente in questo campo assicura una corretta registrazione del nuovo punteggio (massima lunghezza consentita: 8 caratteri).

Data di nascita

E' richiesta, obbligatoriamente, la data di nascita dell'utente che ha effettuato il record; questo dato, utilizzato esclusivamente per fini di catalogazione, verrà utilizzato per selezionare la categoria a cui assegnare il record.

Titolo

OM o YL; questo dato, come il precedente, verrà utilizzato per la selezione della categoria a cui assegnare il record

Nome

Campo, non obbligatorio, in cui specificare il nome dell'utente

Cognome

Campo, non obbligatorio, in cui specificare il cognome dell'utente

Nota

Campo, non obbligatorio, in cui specificare un messaggio da includere nell'email

Fotografia

Una delle possibilità offerte, solamente tramite il server SMTP del RufzXP, è l'invio della foto dell'utente per la pubblicazione sul sito internet. L'immagine, selezionata tramite il pulsante Scegli foto, deve obbligatoriamente essere inferiore ai 100 KByte e, preferibilmente, deve essere orientata verticalmente (lunghezza di 256 punti).

Un volta spedita, appare la scritta Inviata sull'immagine stessa e, soprattutto, il controllo Invia viene deselezionato: desiderando spedire nuovamente la foto (magari per un aggiornamento con una più recente), è necessario riselezionare questo controllo. Il tasto Elimina foto, come si può facilmente intuire, elimina la foto selezionata senza cancellarla completamente dall'hard disk!

Tutte queste opzioni, inerenti la fotografia, sono disponibili solamente se si è deciso di inviare il record direttamente da RufzXP. In caso contrario, tutti i controlli risulteranno disabilitati, così come l'eventuale immagine selezionata precedentemente: sarà comunque possibile allegare una foto all'email tramite il proprio client di posta locale.

Dati email utente

Questi campi sono necessari per consentire l'invio diretto del record.

  • Email: è richiesto l'inserimento del proprio indirizzo di posta elettronica, secondo il ben conosciuto formato username@dominio

  • Server SMTP: è il server per la posta "in uscita". Se utilizzate un client (Outlook Express, Pegasus, Eudora, Pine, ecc., ecc.), è lo stesso SMTP server specificato nelle sue impostazioni.

  • Porta: è la porta utilizzata per connettersi al server SMTP. Solitamente è la numero 25 ma, in caso di necessità (software antivirus, firewall, rete aziendale, ecc., ecc.) è possibile specificarne una diversa.

  • Protocollo di autenticazione: protocollo utilizzato nel caso sia necessaria una procedura di autenticazione per connettersi al server SMTP. E' possibile scegliere una delle seguenti opzioni:

    • Nessuna autenticazione: non viene effettuata alcuna procedura di autenticazione

    • Semplice (testo in chiaro): viene effettuata una procedura "in chiaro". Lo username e la password vengono inviati senza alcuna criptazione
    • NTLM: lo username e la password vengono inviati al server utilizzando il sistema NTLM

  • Username: nome utente utilizzato durante la procedura di autenticazione

  • Password: password utilizzata durante la procedura di autenticazione

  • Utilizza il client locale: permette di scegliere la modalità di invio record. Selezionando quest'opzione, verrà aperto il client di posta locale e preconfigurato un email: l'invio effettivo avverrà durante la prossima sessione, a richiesta dell'utente. Nel caso non fosse registrato nel sistema alcun client di posta (come principale), quest'opzione non sarà disponibile!

  • Utilizza il server SMTP indicato: permette di scegliere la modalità di invio record. Selezionando quest'opzione, sarà possibile inviare il record, selezionato precedentemente, direttamente dal RufzXP (è richiesta, naturalmente, una connessione attiva ad Internet)

  • Utilizza un servizio WebMail: permette di scegliere la modalità di invio record. Selezionando quest'opzione, verrà aperta una finestra contenente l'email da inviare: sarà dunque possibile copiarlo negli appunti, tramite l'apposito pulsante, o effettuare un'operazione di "drag & drop" verso un form per l'invio diretto tramite un servizio di WebMail.

Pulsanti di controllo

Invia record

Come è facilmente intuibile, la pressione di questo pulsante avvia la procedura di invio del record selezionato: diretta, nel caso si sia scelto l'utilizzo del server SMTP di RufzXP, o tramite il client locale in caso contrario.

Prima dell'avvio di una procedura, il programma effettua un test di controllo sui dati: nel caso vengano riscontrati degli errori o delle incongruenze, una finestra di dialogo segnalerà all'utente come risolvere i problemi.


International TopList Form

Finestra della Toplist internazionale

Da qui, è possibile visualizzare i record mondiali, suddivisi per categoria secondo le direttive della IARU; i record personali (presenti all'interno dell'archivio record attivo) sono inseriti automaticamente e comparati a quelli presenti nella TopList internazionale. I dati personali sono salvati localmente e non vengono inviati automaticamente, per la pubblicazione, al sito del RufzXP.

La finestra è suddivisa in 4 parti principali:

  • Lista della Topscore internazionale: mostra i nominativi ed il relativo punteggio record pubblicati su www.RufzXP.net (viene inoltre indicata la velocità massima ottenuta durante il tentantivo). I record sono visualizzati utilizzando i seguenti colori:

    • Record pubblicati sul sito web: nero

    • Record ottenuti da utenti la cui categoria di età è cambiata: grigio;

    • Record appena pubblicati (new entry): grassetto nero;

    • Record locali: grassetto rosso.

  • Lista della Topspeed internazionale: mostra i nominativi e la relativa velocità record, oltre i 350 cpm (70 wpm), pubblicati su www.RufzXP.net;

  • Immagini dei Top scorer: mostra le fotografie dei top scorer. Le immagini si trovano sul sito web del RufzXP e possono essere scaricate direttamente da questa finestra. Nel caso si rendesse disponibile una versione aggiornata di un'immagine, RufzXP avviserà l'utente di scaricarla: al contrario, nel caso una foto venisse rimossa dal sito web principale, quest'ultima verrà automaticamente cancellata anche dall'hard disk locale;

  • News: mostra i messaggi e le informazioni settimanali dal sito web del RufzXP (se presenti);

Non appena viene aperta questa finestra, RufzXP verifica la presenza di un archivio locale della TopList internazionale: nel caso non esista o la versione sia scaduta, una nuova lista viene scaricata dal sito web principale del RufzXP (solamente se è disponibile una connessione ad Internet). Di solito, una nuova versione viene pubblicata ogni Lunedì attorno alle ore 20:00 UTC.

Categorie

Tramite questi controlli è possibile selezionare quale categoria visualizzare. I record locali, appartenenti alla categoria richiesta, sono inseriti automaticamente e contrassegnati dal colore rosso. Se cliccati 2 volte, vengono mostrate le informazioni personali relative al nominativo selezionato.

Dati necessari alla classificazione

Grazie a questi controlli è possibile specificare la data di nascita ed il titolo dell'utente (OM o YL): questi dati sono utilizzati solamente per motivi di classificazione e non verranno pubblicati! Nel caso la categoria visualizzata non fosse coerente con le nuove informazioni (età fuori limite o titolo non coerente), verrà cambiata automaticamente.

Controlli secondari

  • Scarica tutte le foto disponibili: se premuto durante una connessione (computer on-line), scarica tutte le fotografie presenti sul sito principale del RufzXP;

  • Scarica la TopList Internazionale: se premuto durante una connessione (computer on-line), controlla la Toplist internazionale: nel caso fosse disponibile una nuova versione, RufzXP la preleva immediatamente;

  • Scaricamento immagine: questo pulsante è visibile solamente se la fotografia del Top scorer è disponibile sul sito web del RufzXP. Se premuto, scarica l'immagine richiesta;

  • Cancella: se premuto, chiude la finestra della Toplist internazionale: le modifiche alla data di nascita ed al titolo, se presenti, vengono cancellate;

  • Esci: se premuto, tutti i nuovi dati personali vengono confermati e salvati: al termine, la finestra della Toplist internazionale viene chiusa.

Window File Menu

  • Scarica tutte le immagini disponibili: se premuto durante una connessione (computer on-line), scarica tutte le immagini presenti dal sito web del RufzXP;

  • Scarica Toplist Internazionale: se premuto durante una connessione (computer on-line), verifica la pubblicazione di una nuova Toplist internazionale: nel caso fosse disponibile, RufzXP la preleva immediatamente;

  • Cancella: se premuto, chiude la finestra della Toplist internazionale: le modifiche alla data di nascita ed al titolo, se presenti, vengono cancellate;

  • Esci: se premuto, tutti i nuovi dati personali vengono confermati e salvati: al termine, la finestra della Toplist internazionale viene chiusa.


Option Form

Finestra delle opzioni

(Option Form)

Questa è la finestra principale delle opzioni: da qui, è possibile configurare ogni aspetto del RufzXP.

La finestra è suddivisa in 4 parti principali:

  • Controlli del suono: definizione della forma d'onda e selezione della scheda audio

  • Valori di default: nominativo principale, scala (CPM o WPM) e velocità iniziale

  • Opzioni generali

  • Controlli accessori

Controlli del suono

Per mezzo di questi controlli, è possibile definire quasi ogni parametro relativo alla forma d'onda che verrà utilizzata per la trasmissione. In particolare, è possibile variarne:

  • Frequenza: il valore selezionabile, compreso fra i 650 ed i 1200 Hz, indica il centro dell'intervallo, di 400Hz d'ampiezza, all'interno del quale verrà scelta la frequenza di trasmissione. Premendo il pulsante posto immediatamente sotto il controllo (vi è riportata la frequenza), verranno trasmesse nell'ordine la frequenza centrale (MM), quella inferiore (LL) e quella superiore (UU). Premere nuovamente il pulsante per interrompere la trasmissione.

  • Fade in: indica il tempo, espresso in millisecondi (da 0.0 a 0.7), impiegato per ammorbidire l'attacco del suono. Utilissimo in caso d'utilizzo di computer, o di schede audio, particolarmente lenti o datati: un valore più elevato, in questo caso, impedisce la formazione dei click (disturbi di campionatura). Premendo il pulsante posto immediatamente sotto il controllo, verranno trasmesse delle "V" in sequenza.

  • Fade out: indica il tempo, espresso in millisecondi (da 0.0 a 0.7), impiegato per ammorbidire la chiusura del suono. Utilissimo in caso d'utilizzo di computer, o di schede audio, particolarmente lenti o datati: un valore più elevato, in questo caso, impedisce la formazione dei click (disturbi di campionatura). Premendo il pulsante posto immediatamente sotto il controllo, verranno trasmesse delle "V" in sequenza.

  • Volume: il valore selezionabile è compreso fra 0 e 100 (default: 50). Premendo il pulsante posto immediatamente sotto il controllo, verranno trasmesse delle "V" in sequenza.

  • Forma d'onda: consente la selezione fra 3 tipi diversi: Sinusoide, Dente di sega ed Onda quadra. Si rimanda alla lettura di un testo specifico per la definizione di queste forme d'onda.

  • Scheda audio: permette la selezione della scheda audio a cui verrà inviata la trasmissione: è inoltre supportato l'uso dell'altoparlante interno (in questo caso, però, i controlli del volume e dei "fade" verranno disabilitati).

Valori di default

Sono quelli relativi al nominativo principale, alla scala utilizzata per indicare la velocità ed alla velocità iniziale stessa.

  • Nominativo principale: è l'indicativo utente che viene utilizzato ogni qualvolta non ne venga esplicitamente indicato uno. Ad esempio, deselezionando l'opzione Chiedi nominativo, all'inizio del tentativo non verrà richiesto alcun indicativo e, quindi, verrà utilizzato questo per la registrazione del record nell'archivio attivo. Massima lunghezza consentita: 8 caratteri.

  • Scala (CPM o WPM): la pressione di questo pulsante consente il cambiamento della scala delle velocità utilizzata da RufzXP (da CPM a WPM e viceversa): qualsiasi dato indicato, relativo alla velocità, verrà riportato utilizzando la scala richiesta.

  • Velocità iniziale: è la velocità con cui verranno iniziati i tentativi, a meno che non venga esplicitamente richiesta. A seconda della modalità selezionata, definisce due valori di velocità: quello relativo ai modi TopList, Contest ed HST e quello con cui inizieranno le sessioni d'allenamento.

Opzioni generali

Sono quelle relative sia al tentativo che al programma in generale; eccone, di seguito, una descrizione dettagliata:

  • Salva tentativo: attivando quest'opzione, al termine di ogni tentativo verrà salvato un file, contenente i suoi dati completi, nella cartella Attempts. In questo modo, sarà possibile richiamarli in qualsiasi momento per mezzo della finestra archivio record.

  • Nascondi tentativo: attivando quest'opzione, durante le modalità TopList e Trainer i dati relativi al tentativo verranno nascosti: al contrario, durante i modi HST e Contest saranno visibili i campi "Punteggio" e "Velocità" attuale. In entrambi i casi, la barra di stato non verrà mostrata.

  • Schermata iniziale: all'apertura del programma, verrà mostrata o meno la finestra di benvenuto (splash screen).

  • Mostra archivio record: attivando quest'opzione, alla fine di ogni tentativo (salvo durante i contest, liberi o HST) verrà visualizzata la classifica generale: in caso contrario, verranno riportati solamente gli ultimi dati.

  • International TopList: attivando quest'opzione, è reso disponibile il supporto della TopList Internazionale (menù relativi nella finestra principale e nell'archivio dei record).

  • Client di rete: attiva il client di rete di RufzXP (consente la connessione al server di RufzXP durante i contest on-line).

  • Chiusura rapida: attivando quest'opzione, la chiusura del programma avverrà immediatamente quando richiesto: in caso contrario, verrà chiesta un'ulteriore conferma del comando.

  • Effetti sonori: attivando quest'opzione, il RufzXP genererà un suono ogni qualvolta verrà confermato un comando (trasmettendo una K) e durante l'uscita dal programma (inviando i 73 di rito :-) ): in caso contrario, non verrà trasmesso alcun segnale.

Controlli accessori

Sono quelli associati ai pulsanti Default, Cancella ed OK.

  • Default: la pressione di questo pulsante provoca il ripristino immediato dei valori di default.

  • Cancella: la pressione di questo tasto provoca la cancellazione di tutte le modifiche effettuate e la chiusura della finestra Opzioni.

  • Ok: la pressione di questo tasto conferma i dati visualizzati, li salva e provoca la chiusura della finestra Opzioni.

Menu della finestra opzioni

Menù File

Il menù contiene 7 voci:

  • Test: invia il messaggio "VVV TEST TEST AR", per permettere la verifica delle impostazioni

  • Default: ripristina i valori di default

  • Cancella: cancella tutte le modifica effettuate e provoca la chiusura della finestra Opzioni.

  • OK: conferma i dati visualizzati, li salva e provoca la chiusura della finestra Opzioni.

  • Salva file wave: dopo aver richiesto la conferma dell'operazione, genera e salva sul disco fisso un file in formato wave; il suo interno contiene una serie di messaggi predefiniti (la parola PARIS, per la precisione) ripetuti per la durata di c.a. 1 minuto: in questo modo è possibile, analizzando il file con un software (o un hardware) specifico, rendersi conto dell'assoluta precisione dei segnali generati dal RufzXP.

  • Salva: archivia sull'hard disk tutti i valori delle opzioni visualizzate

  • Salva ed Esci: una volta archiviati sull'hard disk tutti i valori delle opzioni visualizzate, chiude la finestra delle opzioni.

Menù Settaggi

  • Cambia sfondo: offre la possibilità di cambiare lo sfondo visualizzato durate i tentativi (visibile solamente se la finestra principale viene ingrandita al massimo). La selezione avviene mediante l'utilizzo dell'apposita finestra.

  • Seleziona il tasto slash (barra): offre la possibilità di definire il tasto slash (barra "/"). Utile nel caso di tastiere con layout particolari.

  • Password: viene attivata una procedura per l'inserimento, il cambio o la cancellazione della password. Il menù non è attivo durante le modalità Contest ed HST.

Menù Lingua

Il suo utilizzo è semplice ed intuitivo: selezionando l'apposita voce, corrispondente ad un file presente nella cartella Language del programma, la lingua principale viene modificata.Chiunque desiderasse contribuire al progetto RufzXP, traducendolo nella sua lingua, è pregato di contattare gli autori.


Informazioni generali

RufzXP - informazioni generali


Color Code

Codice colore degli errori

(Errors color code)

Per permettere un riconoscimento immediato della correttezza o inesattezza della risposta, viene utilizzato un codice colore secondo le seguenti regole:

Errore | colore rosso
Carattere mancante | colore blu
Carattere in eccesso | colore giallo

Di seguito, alcuni esempi di ricezione:

Il nominativo, o il gruppo, trasmesso è stato ricevuto correttamente: nessun carattere errato.

1 carattere errato nella ricezione del nominativo (o del gruppo).

2 caratteri errati nella ricezione del nominativo (o del gruppo).

3 caratteri errati nella ricezione del nominativo (o del gruppo).

In questo caso specifico, viene segnalata la mancanza di un carattere nella ricezione.

E' stato ricevuto un carattere "extra" nominativo.


Personal callbase - Format

Archivio nominativi personale

(Personal callbase)

Il RufzXP, fra le tante novità, permette l'utilizzo, sia durante i contest liberi che durante le sessioni di allenamento, di un archivio dei nominativi personalizzato. In breve, verrà descritto il suo formato e saranno dati alcuni consigli per la sua compilazione.

Importante: il punteggio ottenuto utilizzando un archivio nominativi personalizzato non è considerato valido per la pubblicazione nella TopList internazionale.

L'archivio personale altro non è che un semplice file di testo (l'estensione non è importante ma viene consigliato di mantenere quella di default: .txt), generabile tranquillamente anche per mezzo del blocco note presente in qualsiasi sistema windows, nel cui interno vengono specificati i nominativi (o i gruppi) da trasmettere uno per riga.

Esempio:

IV3XYM DL4MM IV3NCC DL4MM/P DL2OBF IV3AJT A4/IV3NCC

Un volta salvato con un nome qualsiasi (consiglio di utilizzarne uno sufficientemente descrittivo, come contest2004.txt, esercizi2005.txt, ecc.), è possibile utilizzare l'archivio sia durante un contest libero (non HST) che per il proprio allenamento personale.

Attenzione ai nominativi complessi! Nonostante non ci sia alcun tipo di problema nel crearli o meno, ricordarsi sempre che, per un contest o per una sessione d'allenamento dove si desidera averli in una certa percentuale, è indispensabile inserirne nell'archivio un numero sufficiente. Ad esempio, desiderando una percentuale del 5% di nominativi barrati su di un totale di 40 nominativi trasmessi (per tentativo o sessione), è indispensabile inserire nella lista almeno 2 nominativi barrati.


Password form

Finestra password

(Password form)

La procedura per l'attivazione, l'inserimento, la modifica o la cancellazione delle password è uniformata allo standard normalmente utilizzato da qualsiasi programma che ne implementi l'uso.

Finestra di richiesta password: vengono concessi 3 tentativi per fornire la password corretta. La conferma avviene cliccando sul tasto Ok.

Attivazione password: viene richiesto il doppio inserimento di una password (deve necessariamente essere di una lunghezza compresa fra i 6 ed i 10 caratteri). Nel caso il reinserimento di conferma sia corretto (la stringhe inserite sono identiche), sarà possibile attivare la password cliccando sul pulsante Attiva password.

Cancellazione password: esistono due modi per poter cancellare la password:

  • il primo è molto semplice: se entrambi i campi sono completamente vuoti, è reso disponibile il pulsante Elimina password, la cui pressione provvede alla cancellatura;

  • il secondo metodo è identico a quello utilizzato per attivare la password (verrà comunque richiesto l'inserimento della password da cancellare) con una differenza sostanziale: il primo campo deve essere vuoto. Non appena verrà rilevata la mancanza di una nuova password, RufzXP provvederà alla cancellazione della precedente: tramite la pressione del pulsante Elimina password, la cancellazione verrà confermata.


V.I.G.M. Mode

Modalità V.I.G.M.

(Modalità grafica per utenti con problemi alla vista)

Questa modalità è stata scritta per utenti con problemi alla vista; durante il tentativo, i valori sensibili vengono infatti riportati immediatamente alla destra del prompt principale, permettendo una perfetta lettura a certi hardware specifici, come gli “screen reader” (barre Braille). Il valori riportati sono i seguenti:

  1. Numero progressivo del nominativo : lunghezza del tentativo

  2. Punteggio

  3. Numero dei nominativi ricevuti non correttamente

  4. Velocità massima del tentativo (la scala non viene riportata)

  5. Velocità attuale (la scala non viene riportata)

Se l'opzione Nascondi tentativo è selezionata, vengono mostrati solamente il progressivo ed il punteggio.

La modalità può essere attivata in due modi:

  1. Dalla riga di comando, tramite l'opzione di linea -vigm (per esempio: RufzXP -vigm). In questo modo, RufzXP inizia in modalità VIGM.

  2. Dal prompt di comando; all'inizio del tentativo, invece di inserire il proprio nominativo, è possibile inviare uno dei seguenti comandi:
    VIGMON (per attivare la modalità VIGM)
    VIGMOFF (per disattivare la modalità VIGM)


HAM Code

161 | Con i migliori saluti uniti a baci ed abbracci (73 + 88) |
33 | Saluti affettuosi |
55 | Con i migliori auguri |
73 | Con i migliori saluti |
88 | Baci ed abbracci |
A | Abbreviazione per il numero 1 |
ABT | Circa (About) |
AGN | Ancora (Again) |
ANS | Risposta (Answer) |
ANT | Antenna |
B4 | Prima (Before) |
BC | Radiodiffuso (Broadcast) |
BCNU | Alla prossima (Be Seeing You) |
BD | Cattivo (Bad) |
BK | Ritorno o interruzione (Back or Break) |
BN or BEN | Presente (Been) |
BTU | Passo (Back To You) |
BURO | QSL Bureau |
C | Corretto (Correct) |
CB | Callbook o Banda Cittadina (Callbook or Citizen Band) |
CBA | Indirizzo dal Callbook (Call Book Address) |
CFM | Conferma (Confirm) |
CL | Chiusura della stazione (Closing Station Down) |
CLG | Chiamata (Calling) |
CLR | Clear |
CONDX | Condizioni (Conditions) |
CONGRATS | Congratulazioni (Congratulations) |
CPY | Copia (Copy) |
CQ | Chiamata generale per un QSO (General Call for a QSO (Contact)) |
CUD | Potresti (Could) |
DE | Da (per es. DL4MM de IV3XYM) (From (ex. DL4MM de IV3XYM)) |
DR | Caro (Dear) |
DSW | Ci vediamo (Russo) (See You Again (Russian)) |
DWN | Giù (Down) |
DX | Contatto a lunga distanza (Long Distance Contact) |
EL | Elemento (es. 3 EL Yagi) (Element (ex. 3 EL Yagi)) |
ENUF | Abbastanza (Enough) |
ES | E (And) |
FB | Bel lavoro (gergo radioamatoriale per "ben fatto") Fine Business (Ham jargon for very good) |
FD | Giornata per attività all'aperto (Field Day) |
FER | Per (For) |
FIST | Braccio (caratteristica unica che caratterizza la trasmissione di un operatore Morse) (Unique characterisitc of an operater's sending of CW) |
FONE | Fonia (come AM o SSB) (Phone (as in AM or SSB)) |
FM | Da (From) |
FQ, FREQ | Frequenza (Frequency) |
GA | Buon pomeriggio o procedi (Good Afternoon or Go Ahead) |
GB | Arrivederci (Good Bye) |
GD | Buono o Buona giornata (Good or Good Day) |
GE | Buona sera (Good Evening) |
GG | In progressione (Going) |
GM | Buon giorno (Good Morning) |
GN | Buona notte (Good Night) |
GND | Massa (Ground) |
GP | Ground Plane |
GUD | Buono (Good) |
HAM | Amateur Radio Operator |
HC | Chiamata a casa (Home Call) |
HI | Risata in CW (Laughter on CW) |
HNY | Buon anno (Happy New Year) |
HPE | Spero (Hope) |
HR | Qui o Ham Radio (Here or Ham Radio) |
HV | Ho (Have) |
HVY | Pesante (Heavy) |
HW, HW? | Come o Come mi ricevi ? (How, or How Do You Copy Me?) |
II | Ripeto (I Repeat) |
INV VEE | V invertita (Inverted Vee) |
JA | Giappone (Japan) |
JMP | Salto (Jump) |
K | Prego trasmettere (Please Transmit) |
KN | Può trasmettere solamente la stazione con cui sono collegato (Only the station I am working should transmit) |
KNW | Conosco (Know) |
LID | Operatore scadente (Poor Operator) |
LP | Log periodica (tipo di antenna direzionale) o Via Lunga (Log Periodic (type of directional antenna) or Long Path) |
LSB | Lower Sideband |
LW | Long Wire (type of antenna) |
MGR | QSL Manager |
MNI | Moli (Many) |
MSG | Messaggio (Message) |
MULT | Moltiplicatore (Multiplier) |
N | Abbreviazione per il numero 9 |
NIL | Non ho sentito niente o "Non copiato" (Nothing Heard or No Copy) |
NR | Vicino (Near) |
NW | Adesso o Nord Ovest (Now or North West) |
OB | Vecchio mio (Old Boy) |
OC | Old Chap |
OM | Old Man (operatore esperto) (Old Man (Ham jargon for an experienced operator)) |
OP | Operatore o Nome (Operator, or Name) |
OPR | Operatore o Operare (Operator or Operate) |
OT | Old Timer (radioamatore da lungo tempo) (Old Timer (A long time HAM)) |
PSE | Prego (Please) |
PWR | Potenza (Power) |
PO | Potenza d'uscita (Power Output) |
PFX | Prefisso (Prefix) |
QRA | Il nome della mia stazione è ... (The name of my station is ...) | Qual'è il nome della tua stazione ? (What is the name of your station?)
QRB | La distanza approssimativa fra le nostre stazioni è ... (The approx. distance between our stations is ...) | Quanto sei distante approssimativamente dalla mia stazione ? (How far approximately are you from my station?)
QRK | La comprensibilità del tuo segnale è: (1) Cattiva, (2) Scarsa, (3) Sufficiente, (4) Buona, (5) Eccellente (The readibility of your signal is: (1) Bad, (2) Poor, (3) Fair, (4) Good, (5) Excellent) | Qual'è la comprensibilità del mio segnale ? (What is the readibility of my signal?)
QRL | La frequenza è occupata (The frequency is busy) | E' occupata la frequenza? (Is the frequency busy?)
QRM | La tua trasmissione è disturbata da ... (Your transmission is being interfered with) | E' disturbata la mia trasmissione ? (Is my transmission being interfered with?)
QRN | Sono disturbato da scariche elettrostatiche (I am troubled by static) | Sei disturbato da scariche elettrostatiche ? (Are you troubled by static?)
QRO | Aumenta la potenza (Increase power) | Devo alzare la potenza ? (Should I increase power?)
QRP | Abbassa la potenza. Utilizzato anche per designare una stazione che trasmette a bassa potenza (Decrease power. Also used to designate a station using low power) | Devo abbassare la potenza ? (Should I decrease power?)
QRQ | Trasmetti più velocemente (Send faster) | Devo trasmettere più velocemente ? (Should I send faster?)
QRS | Trasmetti più lentamente (Send slower) | Devo trasmettere più lentamente ? (Should I send slower?)
QRT | Fine della trasmissione (Stop transmitting) | Devo finire la trasmissione ? (Should I stop transmitting?)
QRU | Non ho qualcosa per te (I have nothing for you) | Hai qualcosa per me ? (Have you anything for me?)
QRV | Sono pronto (I am ready) | Sei pronto ? (Are you ready?)
QRX | Per favore, resta in ascolto per ... (Please standby for ...) | Devo restare in attesa ? (Should I standby?)
QRZ | Sei chiamato da ... (You are being called by ...) | Chi mi sta chiamando ? (Who is calling me?)
QSA | La forza del tuo segnale è: (1) Appena percettibile, (2), Debole, (3) Sufficiente, (4) Buona, (5) Eccellente (The strength of your signal is: (1) Barely perceptible, (2) Weak, (3) Fair, (4) Good, (5) Excellent) | Qual'è la forza del mio segnale ? (What is the strength of my signal?)
QSB | Il tuo segnale è affetto da evanescenza (Your signal is fading) | E' il mio segnale affetto da evanescenza ? (Is my signal fading?)
QSK | Posso utilizzare la modalità break-in (I can operate break-in) | Puoi utilizzare la modalià break-in ? (Can you operate break-in?)
QSL | Accetto (o invio) una conferma di collegamento (I acknowledge receipt) | Accetti una conferma di collegamento ? (Do you acknowledge receipt?)
QSO | Posso comunicare con ... (I can communicate with ...) | Puoi comunicare con ... ? (Can you communicate with ...?)
QST | Chiamata generale che precede un messaggio a tutti i radioamatori (General call preceding a message to all amateurs) |
QSX | Sto ascoltando a ... (I am listening on ...) | Ascolterai a ... ? (Will you listen on ...?)
QSY | Cambierò la mia frequenza di trasmissione (I will change my transmit frequency) | Devo cmbiare la mia frequenza di trasmission ? (Should I change my transmit frequency?)
QTC | Ho un messaggio per te (I have traffic for you) | Hai un messaggio per me ? (Do you have traffic for me?)
QTH | La mia ubicazione è ... (My location is ...) | Qual'è la tua ubicazione ? (What is your location?)
QSLL | QSL 100% |
R | Messaggio ricevuto o corretto (Message Received or Correct) |
RCV | Ricevo (Receive) |
RCVD | Ricevuto (Received) |
RCVR | Ricevitore (Receiver) |
RIG | Apparato (Equipment) |
RPRT or RPT | Rapporto o Ripeti (Report or Repeat) |
RX | Ricevitore (Receiver) |
SHUD | Dovrei (Should) |
SIG | Segnale (Signal) |
SK or VA | Questa è la mia ultima trasmissione (This is my last transmission) |
SKED | Schedule |
SN | Presto (Soon) |
SNW | Neve (Snow) |
SP | Via breve (Short Path) |
SRI | Scusa (Sorry) |
STN | Stazione (Station) |
SWL | Ascoltatore di onde corte (Short Wave Listner) |
T | Abbreviazione per il numero 0 (Short hand for the number Zero) |
TEMP | Temperatura (Temperature) |
TEST | Contest |
TFC | Traffico (Traffic) |
TIL | Fino a (Until) |
TKS | Grazie (Thanks) |
TCVR | Ricetrasmettitore (Transceiver) |
TT | Questo (That) |
TU | Grazie (Thank You) |
TX | Trasmettitore (Transmitter) |
TNX | Grazie (Thanks) |
U | Tu (You) |
UFB | Ultra "bel lavoro" (gergo radioamatoriale per "ultra ben fatto") Ultra Fine Business (Ham jargon for very good - excellent) |
UR | Tuo (Your) |
USB | Banda laterale superiore (Upper Sideband) |
VERT | Antenna verticale (Vertical Antenna) |
VY | Molto (Very) |
W | Watts |
WATSA | Cosa stai dicendo (What'Cha Say) |
WID | Con (With) |
WK | Lavoro (Work) |
WKD | Lavorato (gergo radioamatoriale per "contattato") (Worked (Ham jargon for making a contact with a station)) |
WKG | In lavoro (Working) |
WL | Will |
WPM | Parole per minuto (una misura della velocità del codice Morse) (Words Per Minute (a measure of code speed)) |
WRK | Lavoro (Work) |
WUD | Desidero (Would) |
WX | Tempo atmosferico (Weather) |
XCVR | Ricetrasmettitore (Transceiver) |
XMTR | Trasmettitore (Transmitter) |
XTAL | Quarzo (Crystal) |
XYL | Moglie (Wife) |
YF | Moglie (Wife) |
YL | Giovane signora (Young Lady) |
YR, YRS | Tuo o Anno, Tuoi o Anni (Your or Year, Yours or Years) |
Z | Ora Zulu, GMT o UTC (Zulu, GMT, or UTC Time) |
ZZ | Dormire (Sleep) |


RufzXP F.A.Q.

(RufzXP Frequently Asked Question)

In questa sezione verranno fornite alcune risposte alle domande più comuni: nel caso non trovaste nulla che fa' al caso vostro, scrivete pure agli autori.

A cosa serve, di preciso, il RufzXP? | Questa versione del RufzXP-Tancredi, come la precendente, è stata sviluppata per fornire uno strumento adeguato alle esigenze di chiunque voglia migliorare sensibilmente le proprie prestazione nella ricezione del codice Morse.
Quale differenza c'è fra la versione XP e quella 32? | La versione precedente era utilizzabile, per problemi di multitask, esclusivamente da Dos puro o tramite un emulatore (il DOSBox, anche se il processore richiesto doveva essere necessariamente veloce): quest'ultima, invece, funziona perfettamente a partire dalla versione 2000 del Windows.
Di quali librerie, o programmi addizionali, ho bisogno per far funzionare il RufzXP? | Il RufzXP, come la maggior parte dei software di ultima generazione, ha bisogno del Framework 1.1 (o superiore), versione redist: se non dovesse essere presente sul sistema, è possibile scaricarlo cliccando qui. E' inoltre necessaria la presenza delle librerie DirectX 9 o superiori (clicca qui per scaricale) .
Ho creato un nuovo tipo di configurazione in modalità contest e mi piacerebbe utilizzarlo con un'altro computer: è possibile? Come? | Certo che è possibile! :-) Durante la modalità Contest, apri la finestra Settaggi (menu Settaggi della finestra principale), scegli il menu File e premi su "Salva" per memorizzare la configurazione in un file. Quest'ultimo, potrà poi essere utilizzato per configurare un altro computer (menu Apri).
Quando provo ad inserire un valore per la velocità, il programma me la cambia: cosa succede??? | Nulla di cui preoccuparsi. :-) Si è cercato di inserire una valore non presente nella tabella delle velocità: in questo case, RufzXP lo arrotonda a quello più vicino.
Può capitare che io non voglia essere visto mentre mi alleno con il RufzXP. Esiste la possibilità di nascondere velocemente il programma? | Durante un tentativo, tramite la pressione simultanea dei tasti SHIFT ed F4 (SHIFT+F4) l'eventuale trasmissione viene interrotta ed il programma si riduce ad icona, visualizzato nella Task Bar come se fosse il blocco note ;-) Una semplice pressione su quest'icona ripristina il tentativo in corso del RufzXP (il nominativo, se non già inviato 2 volte, viene ritrasmesso). Esiste inoltre la possibilità di chiudere completamente (ed immediatamente) il programma con la combinazione dei tasti SHIFT+F10.
Oggi, in modalità Contest, ho conseguito un risultato meraviglioso e mi piacerebbe vederlo pubblicato nella TopList Internazionale del RufzXP. Sto cercando di spedirlo ma non ci riesco: mi potreste aiutare? | Spiacenti: non è possibile. A causa della variabilità dei settaggi della modalità Contest, è impossibile garantire l'affidabilità del punteggio conseguito; per questo motivo, nella TopList Internazionale del RufzXP verranno pubblicati solamente record ottenuti durante le modalità TopList ed HST.
Non ho la possibilità di connettermi ad Internet da casa (ma c'è un bellissimo "Internet caffè" proprio dietro l'angolo ;-) ): in che modo posso spedirvi un record? | Selezionando l'opzione Utilizza un servizio WebMail dalla finestra per l'invio dei record. Appena il pulsante Invia viene premuto, si apre un form con tutti i dati relativi al tentativo: a questo punto, è possibile copiarli negli appunti di sistema o direttamente in un altro web form (o, se lo desideri, in una nota: una volta salvata, sarà facile inviare il record alla TopList Internazionale del RufzXP dall'internet caffè. ;-D)
Ho trovato un errore mentre stavo utilizzando il RufzXP: a chi lo devo comunicare? Ho un'idea su come migliorare il programma: con chi devo parlare? | Potete scrivere agli autori: appena possibile, il programma verrà corretto e sarà pubblicata una nuova versione. Attenzione: inviare sempre, assieme alla segnalazione, il maggior numero possibile di dettagli su come si è verificato l'errore (sistema operativo, modalità, archivi utilizzati, ecc., ecc.). Idee e critiche sono le benvenute e saranno prese in considerazione per i futuri aggiornamenti.
Vorrei poter contribuire all'ampliamento del RufzXP traducendo il programma (o la documentazione): come posso fare? | La prima cosa da fare è contattare gli autori. Nel caso la traduzione non sia in corso d'opera, vi verrà inviata tutta la documentazione necessaria.
Perché "Tancredi"? | A questa domanda è dedicata un'intera sezione: clicca qui per leggerla. :-)


Legenda

La seguente tabella riporta la spiegazione dei termini maggiormente utilizzati nella documentazione di RufzXP:

Archivio nominativi

File contenente i nominativi, o i gruppi, semplici o complessi trasmessi in ordine casuale dal RufzXP durante i tentativi. L'archivio fornito assieme al programma contiene più di 50000 nominativi (tutti i nominativi sono reali: nessun indicativo è stato inventato)

Archivio record

Archivio contenente i dati (punteggio, errori e velocità raggiunte) relativi a tutti i tentativi sostenuti con il RufzXP

Contest libero

Contest le cui opzioni sono completamente configurabili

Contest HST

Contest con regole prefissate

CPM

Chars Per Minute: una delle due unità di misura della velocità di trasmissione Morse. Corrisponde al numero di lettere, contenute nella parola PARIS, trasmesse in 1 minuto (NB: CPM = WPM * 5)

Gruppi complessi

Gruppi di caratteri contenenti almeno una barra di divisione "/"

Gruppi semplici

Gruppi di caratteri senza alcuna barra di divisione "/"

Limiti velocità

Questa versione del rufz supera abbondantemente qualsiasi limite di velocità raggiunto dalle versioni precedenti: quello superiore è stato fissato a 4166 cpm (833 wpm) mentre quello inferiore a 60 cpm (12 wpm). Ovviamente, alle velocità più elevate il concetto di frequenza viene a cadere. :-)

Nominativi complessi

Nominativi contenenti almeno una barra di divisione "/"

Nominativi semplici

Nominativi senza alcuna barra di divisione "/"

Nominativo personale

Il proprio identificativo, normalmente assegnato a qualsiasi stazione radioamatoriale. Massima lunghezza consentita: 8 caratteri

Nominativo TopList

L'indicativo con cui si è stati registrati sul sito internet che pubblica la TopList mondiale: può corrispondere, e spesso succede, al nominativo personale. Massima lunghezza consentita: 8 caratteri

Opzioni

Parametri generali del RufzXP

Record

A seconda del contesto, può avere due significati:

  1. Punteggio massimo o velocità massima

  2. Dati corrispondenti ad un singolo tentativo (singola riga), in riferimento all'archivio record

Settaggi

Parametri di una singola modalità del RufzXP

Tentativo

Procedura di gara standard del RufzXP: indipendente dalla modalità, corrisponde alla trasmissione-ricezione del codice Morse e conseguente assegnazione del punteggio.

TopList

Modalità principale di gara (utente singolo): 50 gruppi trasmessi con percentuale variabile di nominativi complessi. Il record personale è inviabile al sito internet su cui viene settimanalmente pubblicata la TopList mondiale

TopList internazionale di RufzXP

Lista mondiale, pubblicata settimanalmente su Internet, contenente i punteggi inviati dagli utenti di RufzXP per fini comparativi.

Trainer

Modalità di allenamento ampiamente configurabile. Consigliata per un uso didattico del codice Morse o per consolidare l'apprendimento di un gruppo specifico di caratteri

Velocità iniziale

La velocità, espressa in cpm o wpm, con cui inizia il tentativo

WPM

Words per Minute: una delle due unità di misura della velocità di trasmissione Morse. Corrisponde al numero di parole PARIS trasmesse in 1 minuto (NB: WPM = CPM / 5)


Tancredi

RufzXP: perché "Tancredi"?

Sicuramente, molti di voi si chiederanno perché a questa versione del Rufz sia stato assegnato il nome "Tancredi"... I motivi sono molti ma si cercherà di spiegarne brevemente quelli principali. Innanzitutto, il Tancredi di cui si parla è l'eroe protagonista dell'omonima tragedia di Voltaire, trasposta magistralmente in musica dal genio di Gioachino Rossini in quello che è considerato uno dei capisaldi della storia della musica.

Nel Settembre 2004, uno degli autori, Alessandro Vitiello (IV3XYM), si trovava ad Oviedo per motivi di lavoro e, nel tempo libero, si dilettava con il Rufz32; purtroppo, utilizzando il Windows 2000, aveva dei seri problemi a farlo funzionare bene con il DOSBox e fu proprio in quel periodo che gli venne l'idea di svilupparne una versione per Windows XP: il motivo per cui si trovava li era che sua moglie stava cantando il "Tancredi" di Rossini presso il teatro Campoamor, il principale delle Asturias. Chi è appassionato d'opera conoscerà molto bene il nome della consorte di Alessandro: il mezzosoprano/contralto Daniela Barcellona.

Detto-fatto! Scrisse un email a Mathias Kolpe (DL4MM) proponendo l'idea e chiedendogli di scrivere il programma a 4 mani: per renderla un pochino più concreta, sviluppò anche le prime classi di quello che sarebbe diventato il RufzXP (la parte relativa alla generazione delle forme d'onda è stata programmata assieme a Stefano Bonetti, compositore, programmatore ed esperto di musica elettronica); l'idea piacque molto a Mathias e, qualche settimana più tardi, il progetto decollò: in quel momento Alessandro si trovava a Roma, dove Daniela, manco a dirlo, era impegnata nuovamente nel Tancredi! :-D

Il programma nacque quindi sotto l'influenza di Rossini e ci è sembrato giusto, quindi, dargli il nome di Tancredi (soprattutto per ringraziare Daniela dell'aiuto e della pazienza avuta con Alessandro durante tutti questi mesi :-D).


Authors

Gli autori

DL4MM

IV3XYM

Mathias Kolpe (DL4MM, ex DL3DZZ, ex Y33UL, ex Y66QL)

Ideatore del progetto Rufz e di tutte le versioni precedenti del software. Ha fornito al RufzXP tutti gli algoritmi per il calcolo del punteggio e della velocità, contribuendo al definitivo layout del programma (tentativi, contest e trainer) ed alla progettazione delle classi di carattere generale. Curatore della versione tedesca, del sito principale e della TopList internazionale.

Nato nel 1964, ha ottenuto la sua prima licenza radioamatoriale nel 1981. Fin dagli inizi, si è interessato alle attività DX e Contest: da allora, ha al suo attivo 331 paesi DXCC confermati. Nel 1990 è risultato vincitore europeo del "European DX Contest SSB" ed è un abituale operatore delle stazioni DF0HQ/DA0HQ: inoltre, è sempre stato molto attivo nel mondo della telegrafia ad alta velocità. In questo campo, fin dal 1990, ha partecipato regolarmente ai campionati nazionali (Germania Est) e, nel 1991, a quello mondiale di Nerpeelt (IARU High Speed Telegraphy Championship), in Belgio. Per questo motivo, è divenuto direttore della HST tedesca (DARC) e membro del direttivo IARU HST: al termine del 2006, ha lasciato questi compiti al suo successore e, ora, presta servizio come arbitro internazionale.

Mathias, laureato presso l'Università delle scienze tecnologiche di Dresda, è un ingegnere elettronico e lavora come supervisore ai progetti tecnici nella costruzione di sottostazioni ad alto voltaggio, per conto di una compagnia francese. Durante i suoi studi si è avvicinato alla programmazione in Turbo Pascal ed ha iniziato la sua carriera sviluppando un software dedicato all'analisi dei relè di protezione digitali. A quel periodo risale l'idea del Rufz, implementata in Turbo Pascal e concepita inizialmente per un uso prettamente personale; in breve tempo, invece, il software si è diffuso ed è stato ampiamente apprezzato dalla comunità CW internazionale. Di conseguenza, Mathias decise di perfezionarne la prima versione e di creare e mantenere una lista internazionale dei record (Rufz TopList): in seguito, Rufz divenne una
parte fondamentale dei campionati mondiali di telegrafia ad alta velocità (HST).

Per il suo lavoro, Mathias prese familiarità anche con la programmazione orientata ad oggetti per Windows, sviluppando varie applicazioni in Visual Basic per la gestione dei database (MS Access ed SQL). A causa della mancanza di tempo, dovuta da un lato agli impegni lavorativi e dall'altro a quelli della vita familiare, unita ad una non sufficiente conoscenza della programmazione a "basso livello" per i sistemi Windows, la transizione del Rufz dalla versione per DOS ad una più completa ed esteticamente più sofisticata per windows non era mai stata realizzata fino ad oggi: è stato molto fortunato a trovare un programmatore veramente esperto (vedi sotto) a cui unire le proprie forze nello sviluppo del nuovo RufzXP.

Alessandro Vitiello (IV3XYM - IQRP#578)

Programmatore e co-autore dell'ultima versione del progetto Rufz (RufzXP). Ha ideato e realizzato tutte le classi di carattere generale, quelle relative alla generazione e trasmissione del codice Morse, al trainer ed alla gestione dei dati. Curatore del software e della versione italiana.

Pianista e direttore d’orchestra triestino, ha compiuto i suoi studi con il M° Lorenzo Baldini, perfezionandosi in liederistica e tecnica vocale con il M° Vagn Thordal ed in direzione d'orchestra con il M° Gianluigi Gelmetti, presso la prestigiosa “Accademia Chigiana” di Siena. Ha collaborato con direttori di fama internazionale, quali G. Gelmetti ed A. Zedda, esibendosi sui palcoscenici dei più rinomati festival e teatri (Rossini Opera Festiva di Pesaro, Liceo di Barcellona, Genova, San Sebastian, Lima, Tokio, ecc.).

Collabora regolarmente con cantanti di fama mondiale, sia come accompagnatore che come insegnante specializzato in Rossini e, più genericamente, in Belcanto.

Si è avvicinato a 15 anni, per hobby, al mondo della programmazione, utilizzando un Commodore 64 e scrivendo i suoi primi software in Assembler: in seguito, ha iniziato a sviluppare in C, C++ (sia per sistemi operativi Linux, a partire dalle primissime versioni, che Windows) e, recentemente, in Visual Basic .Net e C# .Net.

Appassionato di elettronica, fin da bambino si è dedicato al mondo della radio, sia come autocostruttore di semplici apparati trasmittenti (prevalentemente limitati al CW) che come SWL. Ha conseguito la patente di operatore di stazione radioamatoriale nel 2002 e da allora, durante i suoi viaggi di lavoro attorno al mondo, trascorre il tempo libero sulle bande HF, operando in QRP (principamente in CW). Dalla sua stazione principale, invece, è operativo anche sulle frequenze satellitari.

Nel 2003, cercando un software che gli permettesse di migliorare la ricezione del codice Morse, dopo averne provati a decine, entrò in possesso di una copia del Rufz32; la sua esperienza nel campo dell'insegnamento musicale gli suggerì immediatamente che la curva di apprendimento suggerita dal programma era quella giusta: partendo da una velocità di ricezione media di 80 cpm (16 wpm) nel giro di 2 mesi stabilì il suo record personale di 245 cpm (49 wpm). In seguito ai problemi di compatibilità fra la versione per DOS ed il sistema operativo allora in uso (Windows 2000), decise di crearne, in collaborazione con Mathias Kolpe, una nuova versione basata sul Microsoft .NET Framework.

Ringraziamenti

Per il loro contributo fondamentale, si ringraziano:

Stefano Bonetti: musicista e programmatore, diplomato in pianoforte e composizione, ha progettato e realizzato le classi relative alla generazione delle forme d'onda assieme ad alcune funzioni accessorie.

Ulf Ehrlich (DL5AXX): ingegnere specializzato in apparati medici, ha fornito gran parte dei nominativi utilizzati per la creazione dell'archivio principale (dal log della stazione DA0HQ/DF0HQ).

Giovanna Ragnetti:traduttrice ed interprete professionista, ha tradotto la maggior parte della documentazione in lingua inglese.

Marco Tuniz (IV3NCC - IQRP#509): ex marconista professionista, radioamatore esperto nella realizzazione d'antenne e d'apparati QRP, ha fornito preziosi suggerimenti e consigli in fase di progettazione del software.

Wolfram Heß (DL1RXA): editore, autore e narratore radio (DL1RXA/DK0DX). Ha collaborato alla traduzione della versione inglese di alcune parti della documentazione.

Dan Flanagan, (W3DF): ha fornito le abbreviazioni utilizzate durante la modalità trainer "Ham code" (http://www.qsl.net/w3df/cwabbrev.html).